Post

1 follower Follow
0
Avatar

AWS outbound NAT not working correctly

Hi guys

I have setup a conference node on AWS recently following the instructions and everything is up and running. I am able to join my VMR via webtrc, but unable to receive media from the conference mode. I have a public cloud deployment with conference node assigned with 172.31.x.x IP and have also assigned a static NAT IP with an elastic IP accessible from outside.

When i look at the status of my conference node i see Tx packets but no Rx packets. I’m using the security groups with inbound/outbound rules mentioned on your documentation. My outbound rule even allows any protocol/range with destination 0.0.0.0. Looks like my outbound NATing is not working correctly, do i have to do something addtional than assigning static NAT IP for the conference node to send media egress over internet?

cheers
Rakesh

Graham Walsh

Please sign in to leave a comment.

3 comments

0
Avatar

Hi Rakesh,

If you’re seeing TX packets on the status page and not RX packets, then the issue is actually with the media connection from the WebRTC client into the Pexip Conferencing Node. This is either due to a NAT configuration error (e.g. having the wrong public address that was allocated from the AWS environment) or something with the inbound security group as configured on your specific VM.

Jordan

Graham Walsh 0 votes
0
Avatar

Just wanted to add, i had to delete and re-enable inbound rule for 0.0.0.0/anywhere to get this work. i guess it wasn’t working for you Jordan until i added your public IP explicitly?
Appreciate your quick help Jordan! 🙂

cheers
Rakesh

Graham Walsh 0 votes
0
Avatar

Good, a common mistake is to allow traffic to 0.0.0.0/0 but only from your VPC bit from anywhere 🙂

Thanks for the update!

Marius

Graham Walsh 0 votes